Rabu, 26 Juni 2013

Routing EIGRP

Sebelum kita membahas tentang routing EIGRP (Enhanced Interior Gateway Routing Protocol), kita bahas terlebih dahulu mengenai router. Router bertugas untuk menyampaikan paket data dari satu jaringan ke jaringan lainnya, jaringan pengirim hanya tahu bahwa tujuan jauh dari router. Dan routerlah yang mengatur mekanisme pengiriman selain itu router juga memilih “jalan terbaik” untuk mencapai tujuan.
Ada dua jenis router berdasarkan cara routingnya
1.      Router Statis
Router Statis adalah Router yang me-rutekan jalur spesifik yang ditentukan oleh user  untuk  meneruskan  paket  dari  sumber  ke  tujuan.  Rute  ini  ditentukan  oleh administrator untuk mengontrol perilaku routing dari IP "internetwork". Rute Statis - Rute yang dipelajari oleh router ketika seorang administrator membentuk rute secara manual. Administrator harus memperbarui atau meng"update" rute statik ini secara manual ketika terjadi perubahan topologi antar jaringan (internetwork). Mengkonfigurasi router statis adalah dengan memasukkan tabel routing secara manual. Tidak terjadi perubahan dinamik dalam tabel ini selama jalur/rute aktif.
2.      Router Dinamis
Router Dinamis adalah Router yang me-rutekan jalur yang dibentuk secara otomatis  oleh  router  itu  sendiri  sesuai  dengan  konfigurasi  yang  dibuat.  Jika  ada perubahan topologi antar jaringan, router otomatis akan membuat ruting yang baru.


Tabel Routing
Supaya  router  bisa  melayani  permintaan  untuk  meneruskan  pengiriman  data, maka router harus mempunyai tabel yang dipakai sebagai patokan data ini harus dikirim ke jaringan yang mana? Tabel yang dipunyai oleh router disebut sebagai tabel routing yang berisi NETID dan Default gatewaynya.

Mengkonfigurasi static routing
Membangun static routing pada router-router tidak begitu sulit. Anda tinggal masuk ke global configuration mode dan jalankan formula berikut pada masing- masing router yang akan dikonfigurasikan :

                   Ip route <destination><mask><next_hop_address>

Berikut ini adalah detail untuk masing-masing opsi :
Ip route                     :   perintah untuk membuat static routing itu sendir
Destination                :   network tujuan yang hendak ditambahkan ke routing table 
Mask                         :   subnet mask yang digunakan dalam network 
Next_hop_address    :   address  dari  hop  router  selanjutnya,  yakni  yang  akan menerima paket dan mem-forward-nya lagi ke network remote. Tidak lain berupa interface router dari router dari network yang terkoneksi secara langsung.

EIGRP (Enhanced Interior Gateway Routing Protocol) adalah routing protocol yang hanya di adopsi oleh router cisco atau sering disebut sebagai proprietary protocol pada CISCO. Dimana EIGRP ini hanya bisa digunakan sesama router CISCO saja dan routing ini tidak didukung dalam jenis router yang lain.
Langkah - langkah
1.      Konfigurasi masing-masing PC :
       PC0

       
       PC1

        PC2





        PC3












        PC4
        

        PC5
        


    PC6
    

        PC7
        








    PC8
    
   
    PC9
    
        
        PC10












        PC11











        PC12











        PC13












        PC14













        PC15











2.      Konfigurasi masing-masing Router
     Router1
     F 0/0 : 172.16.1.33 255.255.255.240
     F 0/1 : 192.168.2.2 255.255.255.240



















     Router2
F 0/0 : 192.168.1.17 255.255.255.240
F 0/1 : 192.168.2.1 255.255.255.240
F 0/0/0 : 10.22.16.66 255.255.255.240
      F 0/1/0 : 172.16.3.3 255.255.255.240




















       Router3
       F 0/0 : 192.168.1.18 255.255.255.240
       F 0/1 : 10.12.1.1 255.255.255.240
       F 0/0/0 : 10.11.2.81 255.255.255.240
       F 0/1/0 : 10.14.3.1 255.255.255.240
















 Router4
 F 0/0 : 172.16.32.1 255.255.255.224
 F 0/1 : 172.16.21.146 255.255.255.240
 F 0/0/0 : 10.22.16.65 255.255.255.240
       F 0/1/0 : 172.16.42.97 255.255.255.240



















       Router5
       F 0/0 : 172.16.32.2 255.255.255.224
       F 0/1 : 192.168.64.52 255.255.255.240
















 Router6
 F 0/0 : 172.16.11.89 255.255.255.248
       F 0/1 : 172.16.21.145 255.255.255.240



















      Router7
      F 0/0 : 192.168.10.1 255.255.255.240
      F 0/1 : 192.168.12.17 255.255.255.240
      F 0/0/0 : 172.16.1.1 255.255.255.240
      F 0/1/0 : 172.16.42.98 255.255.255.240




 3.      Tabel Routing
Private IP address Range :
10.0.0.0 - 10.255.255.255
176.16.0.0 - 172.31.255.255
192.168.0.0 - 192.168.255.255

Network
Subnet Mask
N1
172.16.1.32
255.255.255.240
N2
192.168.2.0
255.255.255.240
N3
192.168.1.16
255.255.255.240
N4
10.12.1.0
255.255.255.240
N5
10.11.2.80
255.255.255.240
N6
10.22.16.64
255.255.255.240
N7
172.16.32.0
255.255.255.224
N8
192.168.64.48
255.255.255.240
N9
172.16.21.144
255.255.255.240
N10
172.16.11.88
255.255.255.248
N11
172.16.42.96
255.255.255.240
N12
192.168.10.0
255.255.255.240
N13
192.168.12.16
255.255.255.240

Router
HOP 0
HOP 1
HOP 2
1
N1 & N2
N3 & N6
N4 & N5 & N7 & N9 & N11
2
N2 & N3 & N6
N1 & N4 & N5 & N7 & N9 & N11
N8 & N10 & N12 & N13
3
N3 & N4 & N5
N2 & N6
N1 & N7 & N9 & N11
4
N6 & N7 & N9 & N11
N2 & N3 & N8 & N10 & N12 & N13
N1 & N4 & N5
5
N7 & N8
N6 & N9 & N11
N2 & N3 & N10 & N12 & N13
6
N9 & N10
N6 & N7 & N11
N2 & N3 & N8 & N12 & N13
7
N11 & N12 & N13
N6 & N7 & N9
N2 & N3 & N8 & N10

Router 1
Network
Subnet Mask
Next Hop
N3
192.168.1.16
255.255.255.240
192.168.2.1
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N6
10.22.16.64
255.255.255.240
192.168.2.1
N7
172.16.32.0
255.255.255.224
10.22.16.65
N8
192.168.64.48
255.255.255.240
172.16.32.2
N9
172.16.21.144
255.255.255.240
10.22.16.65
N10
172.16.11.88
255.255.255.248
172.16.21.145
N11
172.16.42.96
255.255.255.240
10.22.16.65
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 2
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N7
172.16.32.0
255.255.255.224
10.22.16.65
N8
192.168.64.48
255.255.255.240
172.16.32.2
N9
172.16.21.144
255.255.255.240
10.22.16.65
N10
172.16.11.88
255.255.255.248
172.16.21.145
N11
172.16.42.96
255.255.255.240
10.22.16.65
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 3
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N2
192.168.2.0
255.255.255.240
192.168.1.17
N6
10.22.16.64
255.255.255.240
192.168.1.17
N7
172.16.32.0
255.255.255.224
10.22.16.65
N8
192.168.64.48
255.255.255.240
172.16.32.2
N9
172.16.21.144
255.255.255.240
10.22.16.65
N10
172.16.11.88
255.255.255.248
172.16.21.145
N11
172.16.42.96
255.255.255.240
10.22.16.65
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 4
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N2
192.168.2.0
255.255.255.240
10.22.16.66
N3
192.168.1.16
255.255.255.240
10.22.16.66
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N8
192.168.64.48
255.255.255.240
172.16.32.2
N10
172.16.11.88
255.255.255.248
172.16.21.145
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 5
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N2
192.168.2.0
255.255.255.240
10.22.16.66
N3
192.168.1.16
255.255.255.240
10.22.16.66
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N6
10.22.16.64
255.255.255.240
172.16.32.1
N9
172.16.21.144
255.255.255.240
172.16.32.1
N10
172.16.11.88
255.255.255.248
172.16.21.145
N11
172.16.42.96
255.255.255.240
172.16.32.1
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 6
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N2
192.168.2.0
255.255.255.240
10.22.16.66
N3
192.168.1.16
255.255.255.240
10.22.16.66
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N6
10.22.16.64
255.255.255.240
172.16.21.146
N7
172.16.32.0
255.255.255.224
172.16.21.146
N8
192.168.64.48
255.255.255.240
172.16.32.2
N11
172.16.42.96
255.255.255.240
172.16.21.146
N12
192.168.10.0
255.255.255.240
172.16.42.98
N13
192.168.12.16
255.255.255.240
172.16.42.98

Router 7
Network
Subnet Mask
Next Hop
N1
172.16.1.32
255.255.255.240
192.168.2.2
N2
192.168.2.0
255.255.255.240
10.22.16.66
N3
192.168.1.16
255.255.255.240
10.22.16.66
N4
10.12.1.0
255.255.255.240
192.168.1.18
N5
10.11.2.80
255.255.255.240
192.168.1.18
N6
10.22.16.64
255.255.255.240
172.16.42.97
N7
172.16.32.0
255.255.255.224
172.16.42.97
N8
192.168.64.48
255.255.255.240
172.16.32.2
N9
172.16.21.144
255.255.255.240
172.16.42.97
N10
172.16.11.88
255.255.255.248
172.16.21.145

Pada masing-masing router tambahkan perintah :
ip route <network IP> <netmask> <next hop>

Router 1 :
Router(config)#ip route 192.168.1.16 255.255.255.240 192.168.2.1
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 10.22.16.64 255.255.255.240 192.168.2.1
Router(config)#ip route 172.16.32.0 255.255.255.224 10.22.16.65
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.21.144 255.255.255.240 10.22.16.65
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145
Router(config)#ip route 172.16.42.96 255.255.255.240 10.22.16.65
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 2 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 172.16.32.0 255.255.255.224 10.22.16.65
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.21.144 255.255.255.240 10.22.16.65
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145 
Router(config)#ip route 172.16.42.96 255.255.255.240 10.22.16.65
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 3 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.240 192.168.1.17
Router(config)#ip route 10.22.16.64 255.255.255.240 192.168.1.17
Router(config)#ip route 172.16.32.0 255.255.255.224 10.22.16.65
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.21.144 255.255.255.240 10.22.16.65
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145
Router(config)#ip route 172.16.42.96 255.255.255.240 10.22.16.65
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 4 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.240 10.22.16.66
Router(config)#ip route 192.168.1.16 255.255.255.240 10.22.16.66
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 5 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.240 10.22.16.66
Router(config)#ip route 192.168.1.16 255.255.255.240 10.22.16.66
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18 
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 10.22.16.64 255.255.255.240 172.16.32.1
Router(config)#ip route 172.16.21.144 255.255.255.240 172.16.32.1
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145
Router(config)#ip route 172.16.42.96 255.255.255.240 172.16.32.1
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 6 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.240 10.22.16.66
Router(config)#ip route 192.168.1.16 255.255.255.240 10.22.16.66
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 10.22.16.64 255.255.255.240 172.16.21.146
Router(config)#ip route 172.16.32.0 255.255.255.224 172.16.21.146
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.42.96 255.255.255.240 172.16.21.146
Router(config)#ip route 192.168.10.0 255.255.255.240 172.16.42.98
Router(config)#ip route 192.168.12.16 255.255.255.240 172.16.42.98

Router 7 :
Router(config)#ip route 172.16.1.32 255.255.255.240 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.240 10.22.16.66
Router(config)#ip route 192.168.1.16 255.255.255.240 10.22.26.66
Router(config)#ip route 10.12.1.0 255.255.255.240 192.168.1.18
Router(config)#ip route 10.11.2.80 255.255.255.240 192.168.1.18
Router(config)#ip route 10.22.16.64 255.255.255.240 172.16.42.97
Router(config)#ip route 172.16.32.0 255.255.255.224 172.16.42.97
Router(config)#ip route 192.168.64.48 255.255.255.240 172.16.32.2
Router(config)#ip route 172.16.21.144 255.255.255.240 172.16.42.97
Router(config)#ip route 172.16.11.88 255.255.255.248 172.16.21.145

Routing EIGRP (Enhanced Interior Gateway Routing Protocol)
Langkah-langkah :
1.      Menciptakan rute dengan model EIGRP
router eigrp <autonomous system number>   
network <IP network> <wildcard-mask>  
2.      Melihat semua rute ke masing-masing router yang lain show ip route    

Router 1 :
Router(config)#router EIGRP 10
Router(config-router)#network 172.16.1.32 0.0.0.255
Router(config-router)#network 192.168.2.0 0.0.0.255
Router(config-router)#exit

Router 2 :
Router(config)#router eigrp 10
Router(config-router)#network 192.168.1.16 0.0.0.255
Router(config-router)#network 192.168.2.0 0.0.0.255
Router(config-router)#network 10.22.16.64 0.0.0.255
Router(config-router)#exit

Router 3 :
Router(config)#router eigrp 10
Router(config-router)#network 10.12.1.0 0.0.0.255
Router(config-router)#network 10.11.2.80 0.0.0.255
Router(config-router)#network 192.168.1.16 0.0.0.255
Router(config-router)#exit

Router 4 :
Router(config)#router eigrp 10
Router(config-router)#network 10.22.16.64 0.0.0.255
Router(config-router)#network 172.16.32.0 0.0.0.255
Router(config-router)#network 172.16.21.144 0.0.0.255
Router(config-router)#network 172.16.42.96 0.0.0.255
Router(config-router)#exit

Router 5 :
Router(config)#router eigrp 10
Router(config-router)#network 172.16.32.0 0.0.0.255
Router(config-router)#network 192.168.64.48 0.0.0.255
Router(config-router)#exit

Router 6 :
Router(config)#router eigrp 10
Router(config-router)#network 172.16.21.144 0.0.0.255
Router(config-router)#network 172.16.11.88 0.0.0.255
Router(config-router)#exit

Router 7 :
Router(config)#router eigrp 10
Router(config-router)#network 172.16.42.96 0.0.0.255
Router(config-router)#network 192.168.10.0 0.0.0.255
Router(config-router)#network 192.168.12.16 0.0.0.255
Router(config-router)#exit